Oddbean new post about | logout
 it’s real code but not good practice to write code like that 
 Why? 
 u would have to do value.0 to access the first element and value.1 to access the second element. that doesn’t really tell you anything. much better would be:

struct KeyWithPayload<'a> {
    key: u8,
    payload: &'a [u8],
}

value: KeyWithPayload

now you can do value.key to know you’re accessing the “key” and value.payload to access the “payload”. much easier to work with as a human dev 
 That's way more readable.